Начальная страница

Инструкция
по добавлению веб-виджета системы ПОС ЕПГУ и
ПОС «Общественное голосование» на сайт образовательной организации на платформе Ucoz
×

  • Начальная страница
  • Следующая
Инструкция
по добавлению веб-виджета системы ПОС ЕПГУ
и ПОС «Общественное голосование» на сайт образовательной организации на платформе Ucoz
МКУ "Информационно-методический центр"
г.Бугуруслан
2021
(c) МКУ "Информационно-методический центр" г. Бугуруслан, 2021


1. Установка виджета ПОС ЕПГУ

1. Для добавления веб-виджета системы ПОС ЕПГУ на сайт образовательной организации на платформе Ucoz необходимо перейти на сайт и авторизоваться под учётной записью администратора.
2. Далее через панель администратора войти в «Панель управления» сайта.
3. На главной странице «Панели управления» сайтом переходим в раздел «Управление дизайном».
4. В окне «Управление дизайном» жмём на кнопку «Backup шаблонов» для резервного копирования дизайна сайта. В случае неудачного размещения кода веб-виджета, можно будет загрузить резервную копию шаблона.
5. Для резервного копирования по умолчанию доступно 20 записей. Поэтому у вас должна быть активна кнопка «Создать резервную копию». Если данная кнопка отсутствует необходимо удалить из списка наиболее старую по дате запись.
6. После создания резервной копии возвращаемся в раздел «Управление дизайном» и на главной странице данного раздела переходим в подраздел «Нижняя часть сайта».
7. В появившемся окне в поле для редактирования ставим курсор в верхнюю строку (номер строки 1) и два раза жмём на клавиатуре клавишу «Enter». Уже имеющиеся код должен опуститься на две строки ниже (на строку под номером 3). Далее необходимо полностью скопировать код веб-виджета из Приложения 1 к данной инструкции, вернуться в браузер на страницу редактирования шаблона «Нижняя часть сайта». Далее кликнув курсором мышки в начало пустой строки под номером 1, вставить данный код с помощью комбинации клавиш на клавиатуре Ctrl+V и нажимаем кнопку «Сохранить».
8. Открываем новую вкладку в браузере и переходим на сайт. В нижней части сайта должен появиться веб-виджет.

Содержание 1. Установка виджета ПОС ЕПГУ

1.1. Приложение 1 Код виджета ПОС ЕПГУ
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г. Бугуруслан, 2021


1.1. Приложение 1 Код виджета ПОС ЕПГУ

Инструкция
по добавлению веб-виджета системы ПОС ЕПГУ и
ПОС «Общественное голосование» на сайт образовательной организации на платформе Ucoz
×

  • 1. Установка виджета ПОС ЕПГУ
  • 1.1. Приложение 1 Код виджета ПОС ЕПГУ
  • Предыдущая
  • Следующая

1.1. Приложение 1 Код виджета ПОС ЕПГУ

<script src='https://pos.gosuslugi.ru/bin/script.min.js'></script>
<style>
#js-show-iframe-wrapper{position:relative;display:flex;align-items:center;justify-content:center;width:100%;min-width:293px;max-width:100%;background:linear-gradient(138.4deg,#38bafe 26.49%,#2d73bc 79.45%);color:#fff;cursor:pointer}#js-show-iframe-wrapper .pos-banner-fluid *{box-sizing:border-box}#js-show-iframe-wrapper .pos-banner-fluid .pos-banner-btn_2{display:block;width:240px;min-height:56px;font-size:18px;line-height:24px;cursor:pointer;background:#0d4cd3;color:#fff;border:none;border-radius:8px;outline:0}#js-show-iframe-wrapper .pos-banner-fluid .pos-banner-btn_2:hover{background:#1d5deb}#js-show-iframe-wrapper .pos-banner-fluid .pos-banner-btn_2:focus{background:#2a63ad}#js-show-iframe-wrapper .pos-banner-fluid .pos-banner-btn_2:active{background:#2a63ad}@-webkit-keyframes fadeInFromNone{0%{display:none;opacity:0}1%{display:block;opacity:0}100%{display:block;opacity:1}}@keyframes fadeInFromNone{0%{display:none;opacity:0}1%{display:block;opacity:0}100%{display:block;opacity:1}}@font-face{font-family:LatoWebLight;src:url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Light.woff2) format("woff2"),url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Light.woff) format("woff"),url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Light.ttf) format("truetype");font-style:normal;font-weight:400}@font-face{font-family:LatoWeb;src:url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Regular.woff2) format("woff2"),url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Regular.woff) format("woff"),url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Regular.ttf) format("truetype");font-style:normal;font-weight:400}@font-face{font-family:LatoWebBold;src:url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Bold.woff2) format("woff2"),url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Bold.woff) format("woff"),url(https://pos.gosuslugi.ru/bin/fonts/Lato/fonts/Lato-Bold.ttf) format("truetype");font-style:normal;font-weight:400}@font-face{font-family:RobotoWebLight;src:url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Light.woff2) format("woff2"),url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Light.woff) format("woff"),url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Light.ttf) format("truetype");font-style:normal;font-weight:400}@font-face{font-family:RobotoWebRegular;src:url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Regular.woff2) format("woff2"),url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Regular.woff) format("woff"),url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Regular.ttf) format("truetype");font-style:normal;font-weight:400}@font-face{font-family:RobotoWebBold;src:url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Bold.woff2) format("woff2"),url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Bold.woff) format("woff"),url(https://pos.gosuslugi.ru/bin/fonts/Roboto/Roboto-Bold.ttf) format("truetype");font-style:normal;font-weight:400}@font-face{font-family:ScadaWebRegular;src:url(https://pos.gosuslugi.ru/bin/fonts/Scada/Scada-Regular.woff2) format("woff2"),url(https://pos.gosuslugi.ru/bin/fonts/Scada/Scada-Regular.woff) format("woff"),url(https://pos.gosuslugi.ru/bin/fonts/Scada/Scada-Regular.ttf) format("truetype");font-style:normal;font-weight:400}@font-face{font-family:ScadaWebBold;src:url(https://pos.gosuslugi.ru/bin/fonts/Scada/Scada-Bold.woff2) format("woff2"),url(https://pos.gosuslugi.ru/bin/fonts/Scada/Scada-Bold.woff) format("woff"),url(https://pos.gosuslugi.ru/bin/fonts/Scada/Scada-Bold.ttf) format("truetype");font-style:normal;font-weight:400}
</style>
<style>
#js-show-iframe-wrapper{background:var(--pos-banner-fluid-22__background)}#js-show-iframe-wrapper .pos-banner-fluid .pos-banner-btn_2{width:100%;min-height:52px;background:#fff;color:#0b1f33;font-size:16px;font-family:LatoWeb,sans-serif;font-weight:400;padding:0;line-height:1.2}#js-show-iframe-wrapper .pos-banner-fluid .pos-banner-btn_2:active,#js-show-iframe-wrapper .pos-banner-fluid .pos-banner-btn_2:focus,#js-show-iframe-wrapper .pos-banner-fluid .pos-banner-btn_2:hover{background:#e4ecfd}#js-show-iframe-wrapper .bf-22{position:relative;display:grid;grid-template-columns:var(--pos-banner-fluid-22__grid-template-columns);grid-template-rows:var(--pos-banner-fluid-22__grid-template-rows);width:100%;max-width:var(--pos-banner-fluid-22__max-width);box-sizing:border-box;grid-auto-flow:row dense}#js-show-iframe-wrapper .bf-22__decor{background:var(--pos-banner-fluid-22__bg-url) var(--pos-banner-fluid-22__bg-url-position) no-repeat;background-size:cover;background-color:#f8efec;position:relative}#js-show-iframe-wrapper .bf-22__content{display:flex;flex-direction:column;padding:var(--pos-banner-fluid-22__content-padding);grid-row:var(--pos-banner-fluid-22__content-grid-row);justify-content:center}#js-show-iframe-wrapper .bf-22__text{margin:var(--pos-banner-fluid-22__text-margin);font-size:var(--pos-banner-fluid-22__text-font-size);line-height:1.4;font-family:LatoWeb,sans-serif;font-weight:700;color:#fff}#js-show-iframe-wrapper .bf-22__bottom-wrap{display:flex;flex-direction:row;align-items:center}#js-show-iframe-wrapper .bf-22__logo-wrap{position:absolute;top:var(--pos-banner-fluid-22__logo-wrap-top);left:var(--pos-banner-fluid-22__logo-wrap-right);padding:var(--pos-banner-fluid-22__logo-wrap-padding);background:#fff;border-radius:0 0 8px 0}#js-show-iframe-wrapper .bf-22__logo{width:var(--pos-banner-fluid-22__logo-width);margin-left:1px}#js-show-iframe-wrapper .bf-22__slogan{font-family:LatoWeb,sans-serif;font-weight:700;font-size:var(--pos-banner-fluid-22__slogan-font-size);line-height:1.2;color:#005ca9}#js-show-iframe-wrapper .bf-22__btn-wrap{width:100%;max-width:var(--pos-banner-fluid-22__button-wrap-max-width)}
</style >
<div id='js-show-iframe-wrapper'>
<div class='pos-banner-fluid bf-22'>
<div class='bf-22__decor'>
<div class='bf-22__logo-wrap'>
<img
class='bf-22__logo'
src='https://pos.gosuslugi.ru/bin/banner-fluid/gosuslugi-logo-blue.svg'
alt='Госуслуги'
/>
<div class='bf-22__slogan'>Решаем вместе</div >
</div >
</div >
<div class='bf-22__content'>
<div class='bf-22__text'>
Есть предложения по организации учебного процесса или знаете, как сделать школу лучше?
</div >
<div class='bf-22__bottom-wrap'>
<div class='bf-22__btn-wrap'>
<!-- pos-banner-btn_2 не удалять; другие классы не добавлять -->
<button
class='pos-banner-btn_2'
type='button'
>Написать о проблеме
</button >
</div >
</div>
</div >
</div >
</div >
<script>
(function(){
"use strict";function ownKeys(e,t){var n=Object.keys(e);if(Object.getOwnPropertySymbols){var o=Object.getOwnPropertySymbols(e);if(t)o=o.filter(function(t){return Object.getOwnPropertyDescriptor(e,t).enumerable});n.push.apply(n,o)}return n}function _objectSpread(e){for(var t=1;t<arguments.length;t++){var n=null!=arguments[t]?arguments[t]:{};if(t%2)ownKeys(Object(n),true).forEach(function(t){_defineProperty(e,t,n[t])});else if(Object.getOwnPropertyDescriptors)Object.defineProperties(e,Object.getOwnPropertyDescriptors(n));else ownKeys(Object(n)).forEach(function(t){Object.defineProperty(e,t,Object.getOwnPropertyDescriptor(n,t))})}return e}function _defineProperty(e,t,n){if(t in e)Object.defineProperty(e,t,{value:n,enumerable:true,configurable:true,writable:true});else e[t]=n;return e}var POS_PREFIX_22="--pos-banner-fluid-22__",posOptionsInitialBanner22={background:"linear-gradient(#2d73bc 26.49%,#38bafe 79.45%)","grid-template-columns":"100%","grid-template-rows":"262px auto","max-width":"100%","text-font-size":"20px","text-margin":"0 0 24px 0","button-wrap-max-width":"100%","bg-url":"url('https://pos.gosuslugi.ru/bin/banner-fluid/18/banner-fluid-bg-18-2.svg')","bg-url-position":"right bottom","content-padding":"26px 24px 24px","content-grid-row":"0","logo-wrap-padding":"16px 12px 12px","logo-width":"65px","logo-wrap-top":"0","logo-wrap-left":"0","slogan-font-size":"12px"},setStyles=function(e,t){var n=arguments.length>2&&void 0!==arguments[2]?arguments[2]:POS_PREFIX_22;Object.keys(e).forEach(function(o){t.style.setProperty(n+o,e[o])})},removeStyles=function(e,t){var n=arguments.length>2&&void 0!==arguments[2]?arguments[2]:POS_PREFIX_22;Object.keys(e).forEach(function(e){t.style.removeProperty(n+e)})};function changePosBannerOnResize(){var e=document.documentElement,t=_objectSpread({},posOptionsInitialBanner22),n=document.getElementById("js-show-iframe-wrapper"),o=n?n.offsetWidth:document.body.offsetWidth;if(o>340)t["button-wrap-max-width"]="209px";if(o>482)t["content-padding"]="24px",t["text-font-size"]="24px";if(o>568)t["grid-template-columns"]="1fr 292px",t["grid-template-rows"]="100%",t["content-grid-row"]="1",t["content-padding"]="32px 24px",t["bg-url-position"]="calc(100% + 35px) bottom";if(o>610)t["bg-url-position"]="calc(100% + 12px) bottom";if(o>726)t["bg-url-position"]="right bottom";if(o>783)t["grid-template-columns"]="1fr 390px";if(o>820)t["grid-template-columns"]="1fr 420px",t["bg-url-position"]="right bottom";if(o>1098)t["bg-url"]="url('https://pos.gosuslugi.ru/bin/banner-fluid/18/banner-fluid-bg-18-3.svg')",t["bg-url-position"]="calc(100% + 55px) bottom",t["grid-template-columns"]="1fr 557px",t["text-font-size"]="32px",t["content-padding"]="32px 32px 32px 50px",t["logo-width"]="78px",t["slogan-font-size"]="15px",t["logo-wrap-padding"]="20px 16px 16px";if(o>1422)t["max-width"]="1422px",t["grid-template-columns"]="1fr 720px",t["content-padding"]="32px 48px 32px 160px",t.background="linear-gradient(90deg, #2d73bc 5.49%,#38bafe 59.45%, #f8efec 60%)";setStyles(t,e)}changePosBannerOnResize(),window.addEventListener("resize",changePosBannerOnResize),window.onunload=function(){var e=document.documentElement,t=_objectSpread({},posOptionsInitialBanner22);window.removeEventListener("resize",changePosBannerOnResize),removeStyles(t,e)};
})()
</script>
<script>Widget("https://pos.gosuslugi.ru/form", 262134)</script>
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г. Бугуруслан, 2021


2. Установка виджета “Общественное голосование”

10. Для добавления на сайт виджета ПОС «Общественное голосование» необходимо в верхней панели управления администратора сайта перейти на вкладку «Управление дизайном» и выбираем пункт «Включить конструктор».
11. Далее произойдёт переход сайта в режим Конструктора. После в этой же вкладке выбираем пункт «Добавить блок».
12. Цепляем блок курсором мышки и перетаскиваем либо в правую сторону, либо в левую. На многих сайтах присутствует только одна сторона блоков.
13. В поле названия блока переименовываем его в «Голосование», а далее жмём на значок шестерёнки.
14. В появившемся окне выбираем вкладку «HTML» и в тестовом поле комбинацией клавиш «Ctrl+V» вставляем код виджета из Приложение 2. После вставки обязательно нажимаем кнопку «Сохранить».
15. Вновь переходим в панели управления администратора сайта на вкладку «Управление дизайном» и выбираем пункт «Сохранить изменения».
16. Конечный результат должен быть таким.

Содержание 2. Установка виджета “Общественное голосование”

2.1. Приложение 2 Код виджета “Общественное голосование”
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г. Бугуруслан, 2021


2.1. Приложение 2 Код виджета “Общественное голосование”

Инструкция
по добавлению веб-виджета системы ПОС ЕПГУ и
ПОС «Общественное голосование» на сайт образовательной организации на платформе Ucoz
×

  • 2. Установка виджета “Общественное голосование”
  • 2.1. Приложение 2 Код виджета “Общественное голосование”
  • Предыдущая
  • Следующая

2.1. Приложение 2 Код виджета “Общественное голосование”

<iframe id="widgetPosId" src="https://pos.gosuslugi.ru/og/widgets/view?type=[10,20,30,40,50]&fontFamily=Arial&maxPage=5&maxElement=5&updateFrequency=2000&level=30&municipality_id=53708000&startTitleColor=000000&startTextColor=666666&startTextBtnColor=FFFFFF&startBtnBgColor=0063B0&widgetBorderColor=e3e8ee&logoColor=ffffff&phoneHeaderColor=0B40B3&fillSvgHeadColor=ffffff&backgroundColor=ffffff&typeBgColor=F2F8FC&selectColor=2c8ecc&hoverSelectColor=116ca6&itemColor=354052&hoverItemColor=2c8ecc&backgroundItemColor=f9f9fa&paginationColor=000000&backgroundPaginationColor=2862AC&hoverPaginationColor=2862AC&deviderColor=e3e8ee&logoFs=16&selectFs=25&itemFs=15&paginationFs=14&widgetBorderFs=1&startTitleFs=38&startTextFs=18&startTextBtnFs=16" width="210" height="577" style="border:0"></iframe>
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г. Бугуруслан, 2021


3. Техническая поддержка

1. Если у вас возникают вопросы технического характера, прошу написать об этом в специальную группу в Telegram.
t.me/joinchat/35NTF3el669IM2My
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г. Бугуруслан, 2021