Главная

Как разместить раздел food на образовательном сайте
Руководство пользователя
×

  • Главная
  • Следующая
Как разместить раздел food на образовательном сайте
Инструкция по размещению ежедневного меню горячего питания на сайте общеобразовательной организации в виде электронной таблицы
для автоматического мониторинга.
(c) МКУ "Информационно-методический центр" г.Бугуруслан, 2021


Оглавление

Что требуется сделать общеобразовательной организации
Основной способ решения вопроса создания страницы с адресом food
Оформляем страницу food под стиль вашего сайта
Ссылка на источник
Техподдержка
(c) МКУ "Информационно-методический центр" г.Бугуруслан, 2021


Что требуется сделать общеобразовательной организации

1. На сайте общеобразовательной организации создать страницу с названием food, для размещения ежедневных меню.
Важно! Обязательное имя страницы: «food». Это лишь требование, о том как создать страницу / файл index.html читайте в инструкции немного ниже.
2. Создать папку с названием food в файловом менеджере в корне фтп сайта: https://www.ucoz.ru/help/tools/fajlovyj-menedzher
3. Размещать ежедневное фактическое меню в данном разделе каждый день отдельным файлом (в виде электронной таблицы).
Важно! Обязательный формат имени файла ГГГГ-ММ-ДД-sm.xlsx, электронная таблица для меню прилагается.
Примечание! Корень фпт сайта, это тот уровень вложения директорий, который вы видите при первом входе в файловый менеджер сайта, то есть не переходя внутрь других директорий.
Пример адресов и имен файлов
1. Если сайт образовательной организации – http://sitename.ru
2. Тогда раздел сайта с меню – http://sitename.ru/food/
3. Ссылка на файл меню младших классов за 28 апреля 2021 года:
  • •
    http://sitename.ru.ru/food/2021-04-28-sm.xlsx - меню младших классов за 28 апреля 2021 г
  • •
    http://sitename.ru/food/2021-05-12-sm.xlsx - меню младших классов за 12 мая 2021 г
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г.Бугуруслан, 2021


Основной способ решения вопроса создания страницы с адресом food

Как описывалось уже выше, в файловом менеджере нужно в корне FTP создать папку food в папке создать / загрузить файл index.html c стандартной разметкой:
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>Меню горячего питания</title>
</head>
<body>
<h1>Меню горячего питания</h1>
<p> Здесь ваше описание для страницы </p>
<ol>
<li><a href="/food/2021-05-19-sm.xlsx">2021-05-19-sm.xlsx</a></li>
<li><a href="/food/2021-05-20-sm.xlsx">2021-05-20-sm.xlsx</a></li>
<li><a href="/food/2021-05-21-sm.xlsx">2021-05-21-sm.xlsx</a></li>
</ol>
</body>
</html>
Загрузить файл index.html
Примечание! Скачаный файл необходимо извлечь из архива
Примечание!! Примеры ссылок в коде выше, это лишь примеры, вам их нужно заменить на свои ссылки на файлы xlsx, которые вы загружаете в папку food.
В результате данного решения наш файл index.html с папки food будет доступен по адресу sitename.ru/food .
Загружая новые файлы в эту папку, вам придется каждый раз редактировать вручную файл index.html и вручную размещать ссылку на новый файл xlsx.
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г.Бугуруслан, 2021


Оформляем страницу food под стиль вашего сайта

Важно! Если вам код выше не подходит, так как оформление не будет очень красивым, мы предполагаем, что у вас до этого уже была созданная страница для питания на сайте, перейдите на нее, далее нажмите комбинацию клавиш CTRL+U, выделите весь код и скопируйте.
Далее откройте на редактирование файл index.html в папке food удалите весь код, который там будет и вставьте ваш скопированный и сохраните.
В результате мы получим страницу доступную по адресу sitename.ru/food и с идентичным дизайном как у вас на сайте.
В дальнейшем могут возникнуть вопросы, как ее редактировать если вы не разбираетесь в коде.
Когда будет необходимость редактирования и добавления новых файлов, копируете исходник с данного файла ( index.html ) далее открываете редактор в модуле "Редактор страниц" по адресу: ваш-сайт/index/31
В редакторе жмите на кнопку "Источник" и вставляйте скопированный код с файла index.html, после сможете в визуальном редакторе отредактировать страницу, добавить новые элементы и ссылки или удалить что-то ненужное.
После как вы визуально все поправили и добавили ссылку на новый файл, напоминаем, его нужно загрузить в папку food рядом с файлом index.html не удаляя его.
Загрузили файл xlsx, скопировали ссылку на загруженный файл, далее добавляйте ее в визуальном режиме в редакторе как показано на изображении выше.
После как все поправите и добавите ссылки между текста, снова жмем в редакторе кнопку "Источник", копируем готовый код и переносим его в файл index.html.
Примечания:
1. Размещаемый на сайте файл меню в виде электронной таблицы не препятствует оформлению его в виде pdf-файла с цифровым контентом или сканированного с печатью и подписью, что может выполняться параллельно по решению образовательной организации.
Для исключения расхождения информации и дублирования документов публикуемая электронная таблица может использоваться и для целей информирования родителей.
2. Суффикс «-sm» в имени файла электронной таблицы указывает на меню начальных классов общеобразовательных организаций.
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г.Бугуруслан, 2021


Ссылка на источник

Источник: https://www.ucoz.ru/help/instructions/food
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г.Бугуруслан, 2021


Техподдержка

По вопросам информационного и технического характера вступайте в группу:
https://t.me/joinchat/SZkMEDvSD0M2Mjli
Справочная система создана в Dr.Explain

Unregistered version
(c) МКУ "Информационно-методический центр" г.Бугуруслан, 2021